> The Lounge     Printing     STARTT Custom Made Cura for STARTT (Updated 24 July 2017)
Custom Made Cura for STARTT (Updated 24 July 2017)
 STARTT   Started by Jack Keum   2017-06-08 22:20:52 +01:00   Comments: 34    Viewed: 6834

  1. Jack Keum
    Jack Keum Moderator Staff Member
    Hi Everyone,

    We are always working hard to bring 3D printing to everyone, we love to inspire everyone including people who have no experience in 3D printing at all, and that's the reason we introduce the Startt printer to the world. 
    Today we have just made a step closer to seamless 3D printing experience, we have created a custom Cura made just for the Startt printer. 

    Cura for Startt version 1.2: (Updated 24 July 2017)
    1. Fix Preview issue
    2. Other minor bugs

    Previous Cura for Startt version 1.1: (Updated 5 July 2017)
    1. Fixed "Upload Custom Firmware" feature
    2. Fix bugs relating different Z-height when printing second object
    3. Improved default settings for better quality printing
    4. Fixed other bugs.

    Previous Cura for Startt version 1.0: (Updated 15 June 2017)
    1. Access to MyMiniFactory for free 3D content with just one-click 
    2. New version of Cura with better gcode generation  
    3. Preset settings optimised for the Startt. 

    We will continue to work on improving the software. We are also welcome for any feedback and feature request. 

    You can download the software over here: 


     
    Mac and Linux version soon coming!

    Best wishes,
    Jack
    iMakr Engineer
    Jack Keum, 2017-06-08 22:20:52 +01:00
    reddadsteve and Alan Cox likes this.
  2. Jack Keum
    Jack Keum Moderator Staff Member


     
     
     
    Jack Keum, 2017-06-08 22:25:10 +01:00
  3. reddadsteve
    reddadsteve Member Flanders
    @Jack, Great addition to the STARTT, I knew that purchasing the STARTT was a good idea!
    I just downloaded the new Cura and the first thing that caught my eye is the new start and end gcode commands.  I can see a lot of thought and testing went into this and am eager to try it out.

    Steve
    reddadsteve, 2017-06-09 02:43:00 +01:00
  4. MacOSX version?
    Michael Fuselier, 2017-06-09 02:57:40 +01:00
  5. reddadsteve
    reddadsteve Member Flanders
    @Jack, minor problem:
    Windows 10
    Trying to close the program using the "File->Close" hangs and then Windows complains about trying to close the program.  Clicking the X in the upper right hand corner to close the program works fine.
    reddadsteve, 2017-06-09 03:04:14 +01:00
    Jack Keum likes this.
  6. Jack Keum
    Jack Keum Moderator Staff Member






    Thanks reddedsteve, I will pass your message to our software engineers.

    Best,
    Jack
    Jack Keum, 2017-06-09 09:55:45 +01:00
  7. Norm Huntley
    Norm Huntley Member
    Jack: How do you change the build plate size my printers are 150mmx 150mm thanks Norm
    Norm Huntley, 2017-06-09 12:13:42 +01:00
  8. Jack Keum
    Jack Keum Moderator Staff Member





    Hi Norm,

    You can change the setting under Preference->Printer.

    Jack Keum, 2017-06-09 15:17:05 +01:00
  9. Norm Huntley
    Norm Huntley Member
    thanks, I see things about about temperature looking to change it which one
    Norm Huntley, 2017-06-09 19:49:54 +01:00
  10. reddadsteve
    reddadsteve Member Flanders
    Norm,  There are settings for each type of filament and ways of saving new configuration files.  For me, I found the easiest way to make a simple change (such as temperature) is on the main screen where it shows a dropdown for material and profile.  Just below that, there is a slider to choose recommended or custom.  Slide it to custom and click on the material dropdown (not the little gear).  The dropdown will give you a few parameters to modify.  If you want control over more parameters then click on the gear icon and enable which parameters you want quick access to.

    Be sure you learn about profiles and saving configuration changes.

    Hope that helps!  I wanted a default of 210 instead of 200 and went through a bit of trial and error until I understood the above.
    Regards,
    Steve
    reddadsteve, 2017-06-11 03:25:13 +01:00
  11. Tiger Huang
    Tiger Huang Moderator Staff Member London
    Hi, I am the developer of Cura for Startt Software, my name is Tiger Huang.

    We now have a ubuntu (and possibly some other linux distribution) 64 bit version, download link is 
    https://drive.google.com/open?id=0Bx9uFeD6VpHDUjhGOU9sZ3NWS28

    I am currently working on a Mac version, if you are interested in a development build I can send you one. (@Michael)

    If you experience any issue and bug, you can talk to me directly.


    The source code is on github.


    Thanks for trying it out, if you have any suggestions and complains about the software, don’t hesitate to contact me!

    Regards,
    Tiger

    Tiger Huang, 2017-06-15 12:48:47 +01:00
    Alan Cox and Marcos Vidal likes this.
  12. Jack Keum
    Jack Keum Moderator Staff Member
    Please check out the updates! :)
    Jack Keum, 2017-07-05 15:28:26 +01:00
  13. I have updated cura for startt and now there is no way to select material and it does not calculate how much the print will weigh.
    Nathaniel Davis, 2017-07-17 13:24:14 +01:00
  14. Tiger Huang
    Tiger Huang Moderator Staff Member London





    Hi Nathaniel,

    This will be fix in the next update, we are working on this. Thanks.

    The default material should be PLA.

    Tiger
    Tiger Huang, 2017-07-17 13:35:05 +01:00



  15.  Aslo I can not print from my computer via usb. I have to download the gcode to sd and print it from the SD card.The application closes when I click print via usb on Windows 10.
    Nathaniel Davis, 2017-07-17 22:51:03 +01:00
  16. Fkinell
    Fkinell Member
    Hi, I do not seem to be able to update my Startt using the Cura for Startt? I am using the latest version 1.2 ( Although this shows as 1.1.1 in the Help - about menu. Trying to upgrade from Rep' 92.9 to StarttFirmware1.0.hex which I assume is Version 1?

    Help please. 

    Ta

    Glen
    Fkinell, 2017-07-31 15:56:19 +01:00
  17. Hello,
    I just installed the 1.2 version of cura for STARTT
    I installed it without any problem, but when I want to use it, it crash just after the "loading machines" message.
    When I start the program, I saw that the printer restart.
    I am running Windows 10 64bits.
    Have you any idea ?

    Thanks
    Nathan
    Nathan Loudjani, 2017-08-18 11:04:06 +01:00
  18. Adam Carlson
    Adam Carlson Member
    I am trying to use the update feature in the New Cura for STARTT.  

    Relevant debugging details:
    OS: Windows 10 - 64 Pro
    Device: Surface Pro 3
    Version Cura for STARTT: 1.2
    Version of Repetier on Printer: .91

    Issue Details:
    I am trying to connect to the printer, and it will not show it as available.  I have tried to download the Repetier software and it also does not show the device available.

    When I go into the device Manager, it shows up as a RAMPS device under the ports section (in this case under COM3).  It shows that the device is functioning normally and that there are no yellow triangles around it.  

    I do not have easy access to a ISP nor an Arduino.  I have though checked in the Arduino IDE (man that really is what they call an IDE???) and it does recognize that there is a device to connect to on COM3.

    What are the options here?  I really do not want to have to go and purchase an Arduino just to do this, and then I would need to have the source files to be able to do it.

    Thanks,
    Adam
    Adam Carlson, 2017-08-30 05:14:30 +01:00
  19. reddadsteve
    reddadsteve Member Flanders
    Adam,
    I had a lot of problems myself but eventually got it working by 'accident'.  I'm sharing what I've learned and hopefully it is useful in your case.

    1-I do not know why but I have a number of USB ports on my computer and none of them initally connected to the printer.  I then tried the USB port on my keyboard and it worked.  I do not know if it was because it was a USB 1.0 or because it was powered differently but it worked.  If you have any way of trying different USB ports or a USB hub it may be helpful.
    2-There is also the potential issue of the USB cable.  I've read many help forums where a solution was a shorter USB cable or better shielded cable.  Moving the printer/computer to avoid any potential interference is also recommended.
    3-Have you synched your baud speed?  I'm not sure if this only applies to problems after a connection occurs or if it also prevents the connection in the first place.
    4-Have you used your USB for any other printers before?  I had installed the Makerbot software for my first printer and that software installs a service that grabs the USB port and does not let go unless the service is killed.

    The above may or may not be useful in your case.

    Steve
    reddadsteve, 2017-08-30 16:55:00 +01:00
  20. Adam Carlson
    Adam Carlson Member
    Steve,

    Thanks for getting back to me.  Here are the answers below.

    I have not tried any more USB ports as I only have 1.  I will, though, try to add a hub to see if that helps.

    I will also try a different cable.  I will have to see if there are any more type B cables lying around the house.  Not a common cord around here.

    I did adjust the Baud rate to the 115200 that seems to be suggested around the forums.  I also tried a few others, but without any luck.

    This computer has not been used with any other printers.




    Adam Carlson, 2017-08-30 16:59:53 +01:00
  21. Page 1 / 2

    (You must log in or sign up to post here)

Report Post

Write your reason

Log in | Sign up
Terms & Conditions!
Help!