> The Lounge     Printing     STARTT Maximum Printable Area
Maximum Printable Area
 STARTT   Started by Jack Keum   2017-08-09 16:56:03 +01:00   Comments: 15    Viewed: 1503

  1. Jack Keum
    Jack Keum Moderator Staff Member
    Hi all,

    We have received a few complaints about the reduced printable area after the firmware update. We have identified the cause of this and made a short guide to tackle this issue. The next batch of printer will not have this issue so if you haven't receive your printer yet you will not be affected by this. 

    Jack Keum, 2017-08-09 16:56:04 +01:00
  2. Lenny
    Lenny Member
    It did not work on my mac. I never managed to have the printer connected to the software. However I installed a VM with vmware and I manage to do it with Windows 10. You need to be sure to do it with the good baud rate (115200).
    Lenny, 2017-08-10 23:31:31 +01:00

    Hi, how are you? I can not get the printer to print in the center,

    And these settings that were passed do not have access as well.


    I would like to solve the problem because I can not print since I started the printer.


    Marcos Serafim, 2017-08-16 17:21:24 +01:00
  4. i have the problem also.
    When i fix it as described does the printer keep the settings like that, or do i have to do this every time
    I print via sd card and my computer is not close to the printer, so conecting it every time is not possible
    Koen Molemans, 2017-12-24 21:32:22 +00:00
  5. i can not open the eeprom settings in repetier when the printer is connected
    please make some downloadable working firmware ASAP as i need to print something urgently but with this error i can not do it
    Koen Molemans, 2017-12-25 20:30:00 +00:00
  6. Nigel
    Nigel Member

    Hi Jack

    Could you help me here. My printer does not print beyond 118mm in the y axis. I viewed your pdf on how to change the printable size area but am a bit confused about these settings and the cura settings (using the downloaded version for Startt).
    My scenario, I am printing a piece that is 90mm. Cura has a setting that gives 140mm in the y axis. Cura is placing the object in the centre so leaving a gap of 25mm at each end. But the printer doesn't print upto 140mm so cuts off the last 3mm.
    Should I be changing the default settings in Cura to match those given in your pdf ?


    Nigel, 2017-12-30 18:32:18 +00:00
  7. still no working sollution?
    is there a way to do a rollback of the firmware update? in the old cversion there was no problem...
    Koen Molemans, 2018-01-04 21:13:42 +00:00
  8. Tim Morris
    Tim Morris Member
    If you can't get repetier host to work for some reason, you can try running this gcode to set the print limits to those given in the pdf instructions, or edit the file to change the values if you want.
    Tim Morris, 2018-01-07 20:10:44 +00:00
    Attached files : SetPrintLimits.gcode
  9. stupid question, how do i run this?
    Koen Molemans, 2018-01-07 21:48:52 +00:00
  10. Tim Morris
    Tim Morris Member
    Stick it on your SD card and tell it to print it. You won't see anything happen, but it should have changed your stored settings.
    Tim Morris, 2018-01-08 01:49:46 +00:00
  11. This seems to work :D
    Thank you very much.

    Only isue u have now is that the print is completely off-center.
    I have about 2cm spacing on the left and only 1mm on the right of the printbed.
    Koen Molemans, 2018-01-08 19:44:33 +00:00
  12. Tim Morris
    Tim Morris Member
    OK. So now we need to work out the correct numbers and you can edit the g-code match your printer. The settings in the file are the ones supplied by imakr and they look a bit wrong to me.

    I reckon you have a 120 by 120 printable area on a standard startt.

    So I suggest setting up for that to start with. You need to home your printer and measure where your nozzle is relative to the printable area. e.g. if your nozzle is 5mm to the left of the bed, you need to set 'X min pos' = -5 and 'X max length' = 125. For the y axis, measure relative to the bottom of the printable area which is just above the clip.

    Just change the numbers after the X in the g code, so for example if your home position is x = -5 and y = 0, you would change the file to:-
    M206 T3 P133 X-5 ; X min pos
    M206 T3 P137 X0 ; Y min pos
    M206 T3 P141 X0 ; Z min pos
    M206 T3 P145 X125 ; X max length
    M206 T3 P149 X120 ; Y max length
    M206 T3 P153 X125 ; Z max length

    Don't forget to set your slicer configuration to match your print area i.e. 120mmx120mm.
    Tim Morris, 2018-01-09 01:25:55 +00:00
    Axel Richter likes this.
  13. You Sir, are a hero ;)
    Thank you so much for the help.
    This works perfectly for me.

    Now one more problem to solve, and it would be a great printer for me.
    My teflon tube keeps popping loose on the side where the puller for the filament is (no idea how to call it in english).

    Koen Molemans, 2018-01-09 05:22:25 +00:00
  14. Norm Huntley
    Norm Huntley Member
    replace the fitting you can get them from Amazon, had the same problem.
    Norm Huntley, 2018-01-11 17:07:42 +00:00
  15. Hi Jack,

    Is it possible if you can pin this on the forum? I got the printer around a year ago and I've been looking for the solution to the printing area issue for a while. I've found this page in a long time, and if others want to solve this issue they might want to access this information quicker before it goes backward in the forums. Also, kudos to you and your team Jack. I appreciate the help in fixing my printer's print area.

    For those who are recently fixing their print area, instead of going to Printer --> EEPROM Settings in the .pdf, go to Config --> Firmware EEPROM Configuration (or just press Alt+e in the Repetier-Host V2.1.3 software). Change the configurations from there. For others, I recommend these settings:

    X min pos -7.000mm
    Y min pos 0.000mm
    Z min pos 0.000mm
    X max length 126.000mm
    Y max length 140.000mm
    Z max length 132.000mm

    This gives the maximum build area without any hardware changes.

    Note: In order to print taller objects, you need to replace your PTFE (Teflon) tube with a larger one and loop it around the back and over the display. You can also replace the extruder motor so it is located on top of the machine. Either way, you can reach Z heights of around 130 mm. See the attached picture for a replaced extruder motor.

    Note 2: In order to fully print 140mm on the Y-axis, you need to shift your build plate forward so that when y=0, the nozzle is just on the rim of the build plate. You can glue the build plate to the acrylic for maximum build area (don't need paper clips). Make sure to re-level to account for the glue. See the picture attached for clarification.

    Yadunandan Vijayaraman, 2018-11-23 17:28:53 +00:00
    Attached files : My STARTT Printer.jpg
  16. (You must log in or sign up to post here)

Report Post

Write your reason

Log in | Sign up
Terms & Conditions!