> The Lounge     Printing     STARTT USB Connection Problems
USB Connection Problems
 STARTT   Started by Susan Woods   2017-03-12 00:21:15 +00:00   Comments: 49    Viewed: 9359

  1. Susan Woods
    Susan Woods Member England
    Having USB Connection Issues?
    Susan Woods, 2017-03-12 00:21:16 +00:00
  2. Susan Woods
    Susan Woods Member England
    Hi Guys,

    I'm having real troubles trying to connect to the Startt/TronXY via USB, either in Cura or Simplify3D.

    Cura just sulks and occasionally does weird stuff when I mess with the machine settings baud rate, and then disconnects.

    S3D is a little better in that the Machine Control Panel shows more of what is going on - mostly framing errors - no matter what baud is set.

    I have also worked my way through the baud rates on the printer itself. Connect. Disconnect. Connect.....

    Tried different cables. USB2. USB3. Computers. Win10. Win7. LinMint. I think my UART crystal might frequency might be out :(
    Anyone else had this?

    It's not a deal-breaker, but that memory card position is a bit of a PITA. ;)

    Susi xx
    Susan Woods, 2017-03-12 00:30:27 +00:00
  3. Hey Susan!

    I confirm. Same here.
    While printing from sdcard works 100% reliably, the USB connection turns out to be unreliable.

    When first connecting the cable, I see this in dmesg:
    usb 1-2: new full-speed USB device number 6 using xhci_hcd
    usb 1-2: New USB device found, idVendor=0403, idProduct=6001
    usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-2: Product: FT232R USB UART
    usb 1-2: Manufacturer: FTDI
    usb 1-2: SerialNumber: 00000000
    ftdi_sio 1-2:1.0: FTDI USB Serial Device converter detected
    usb 1-2: Detected FT232RL
    usb 1-2: FTDI USB Serial Device converter now attached to ttyUSB0


    I can use


    screen /dev/ttyUSB0 115200

    to connect and send commands. E.g. a questionmark causes an 'External Reset' response and prints memory stats.

    Cura recognizes the printer directly, adds the option to 'print via USB'. The printer status page shows the hotend temperature rising, after starting a print. But then, the printer does not move in a controlled way, filament feeding started very late. And at some point dmesg showed


    ttyUSB0: 2 input overrun(s)

    Time to stop the experiment and return to sdcard. At least serial handshake is not working for me. Probably the FTDI chip is not initialized properly. Are there any firmware upgrades to fix this?

    Jürgen Weigert, 2017-03-14 09:36:42 +00:00
  4. Jack Keum
    Jack Keum Moderator Staff Member
    Hi guys,

    Thanks for letting me know about this problem. I will discuss with the manufacturer about the firmware. 

    I will keep you guys posted if i get any update. 

    Best,
    Jack
    Jack Keum, 2017-03-14 17:37:13 +00:00
    Susan Woods likes this.
  5. Iker bastida
    Iker bastida Member
    Hello, 
    same problems... i have used octoprint wich raspberry pi 3 but usb errors...
    i have upgrated bootloader and changed firmware (actually i have flashed  Marlin 1.10,) but melzi board dont works ok witch usb connection...
    Iker bastida, 2017-03-16 22:14:12 +00:00
  6. Iker bastida
    Iker bastida Member
    No news about this usb connection problems?
    thanks
    Iker bastida, 2017-03-24 11:34:39 +00:00
  7. Spooky experience tonight: My USB connection seems to work now. The only change is, I relocated the printer to a different building. We are now in the countryside with very little electro-smog here. I'll continue making experiments, I bet it will fail again, when returning to my downtown flat....
    Jürgen Weigert, 2017-03-25 23:37:41 +00:00
  8. Iker bastida
    Iker bastida Member





    thanks for your info! 
    I would like to run octoprint ok.
    Iker bastida, 2017-03-26 23:17:43 +01:00
  9. Jürgen Weigert, 2017-03-27 22:18:16 +01:00
  10. Iker bastida
    Iker bastida Member
    I see your python script this morning (your GitHub si in my Chrome favorites)... thanks for your work.
    Iker bastida, 2017-03-27 22:32:10 +01:00





  11. Hey Jack, is there anything we can do to help with diagnose, fix, test, ...?
    Jürgen Weigert, 2017-04-17 00:25:22 +01:00
  12. Identified one issue with cura: When an empty command is sent, the printer responds with a resend message. cura does that sometimes in a loop for several minutes.

    Sent by cura:

    "nN21*77n"

    Response from the printer:

    "Error:Format errorrnrn
    Resend:21rn
    okrn"

    Here is a patch for cura that avoids this issue:
      https://github.com/fablabnbg/tronxy-xy100/tree/master/debug

    Developers: please also see the serial protocol dumps in the same folder. That may help fix the firmware.

    Despite this fix, I cannot print via USB.
    The long delays are gone now, but there are still strange erratic movement, that look like transmission errors to me.
    Jürgen Weigert, 2017-04-17 19:32:06 +01:00
  13. The editor here is playing tricks on me. I wanted to say backslash-n and backslash-r for carriage-return and linefeed characters... Try again:

    Sent by cura:

    "nN21*77n"

    Response from the printer:

    "Error:Format errorrnrn
    Resend:21rn
    okrn"
    Jürgen Weigert, 2017-04-17 19:39:10 +01:00
  14. \n \r
    Jürgen Weigert, 2017-04-17 19:40:00 +01:00
  15. There are two erratic effects on my STARTT now:
    a) sporadic long travels along the Y axis, and
    b) reversing and feeding huge quantities of filament, the printer slowing down to a crawl while doing so.

    a) disappears, when gcode commands are sent without checksums. See https://github.com/fablabnbg/tronxy-xy100/blob/master/debug/cura240-no-empty-cmd.patch#L37

    My wild guess for a) is that a lower computational load helps receiving the data properly.

    b) disappears when lowering temperature to 100 deg, so that the extruder is disabled. It also does not slow down any more. If the slow down is just a consequence of the long extruder movemements, then this does not mean anything...

    No wild guess for b), I am not yet sure what effect I am observing.

    I'd like to try a lower baud rate next.  The setting from the configuration general menu is reset as soon as the serial line is opened. That is sooooo unhelpful.
    Any pointers how to permanently set the baud rate?
    Jürgen Weigert, 2017-04-17 23:02:33 +01:00
  16. USB works ok for me, but definatly has some issues. Serial port - Auto, Baudrarte 115200 - from a MacBook Pro laptop. Oddly when the job finishes Cura doesn't always show it done, usually it just still says printing. So I have to quit it. Sometimes, it does weird things to the usb ports on the computer and I have to reboot, but that usually fixes it. With my SSD, my laptop reboots in about 15 seconds and resumes in about a minute but its still kind of a pain.
    Michael Fuselier, 2017-04-18 02:33:45 +01:00
  17. Hey Michael! Thanks for the info.
    Cura 2.4.0 has a bug that causes confusion, when the printer sends its statistics after the job is done. If you can see the console output of cura, it is likely that you find somthing saying "an exception occured while handling an exception" near the end of the log.

    When my printer boots, the text "Repetier-0.91" is briefly visible. I believe this is the firmware version. Do you have the same?
    Jürgen Weigert, 2017-04-18 09:55:54 +01:00
  18. Yes indeed, I do believe that is the firmware.  Repetier also makes slicing software buyback I can remember if I gor it to connect or not.
    My email is mfuse (at) me (dot com) by the way. I would like to be able to email some of the people with these printers.
    Michael Fuselier, 2017-04-18 14:55:45 +01:00
  19. I just checked the Repetier site, and they have the .92 firmware on their site. Not sure if it needs to be modified for the Startt or what. Jack Keum, whats the deal? Can we download this firmware and try it? https://www.repetier.com/download-now/
    Michael Fuselier, 2017-04-18 20:48:49 +01:00
  20. reddadsteve
    reddadsteve Member Flanders
    Looks like it's my turn to have a problem.  I have been running fine with the SD card and finally tried to connect via the USB cable.  Windows 10 is not creating a COM device and I get the error: DEVICE_DESCRIPTOR_FAILURE
    I have a Flashforge and have no problem connecting to it, a COM port is created when I plug in the USB to that printer.  I use the same cable on the STARTT and get the error.
    Is there any initialization file required in order to use the USB?  I would think that the problem is on my Windows side.
    Thanks,
    Steve
    reddadsteve, 2017-04-25 18:21:44 +01:00
  21. Page 1 / 3

    (You must log in or sign up to post here)

Report Post

Write your reason

Log in | Sign up
Terms & Conditions!
Help!